Problems executing make for gen2shp

Johan Olanders
Mon Oct 27 11:23:42 CET 2003

Hi again!
I finally got the River Ouse catchment (Sussex, UK) working with GREAT-ER 1.05 
befor I left! Unfortunatley I had to leave the PC. So now I'm setting up a 
another PC back in Sweden to be able to do some re pre-processing.

This time I'm using Mandrake 9.1 GNU/Linux
gen2shp 0.3.1
shapelib 1.2.10

Here are the errors I get

[johan at frodo gen2shp-0.3.1]$ make
cc -I /home/johan/greater/preproc -o gen2shp -lshp gen2shp.c utils.o
/usr//bin/ld: cannot find -lshp
collect2: ld returned 1 exit status
make: *** [gen2shp] Error 1
[johan at frodo gen2shp-0.3.1]$

I guess it's some kind of problem with paths and I've tried to figure out the 
right way to solve it without sucess.

I had the same problems back in UK when running RedHat, that time the problem 
was solved by using already finished rpm's for gen2shp and shapelib. But they 
won't install correctly in Mandrake 9.1 (I'm using Mandrake now because my 
old IBM 6091 screen is more difficult to get working with RedHat.)

(I remember Jan-Oliver told me last time to specify where to find the and adapt the CFLAGS to this but I can't find a file 
after uncompressing shapelib 1.2.10)

Any ideas? / Johan

More information about the Great-er-list mailing list

This site is hosted by Intevation GmbH (Datenschutzerklärung und Impressum | Privacy Policy and Imprint)