Problems executing make for gen2shp

Jan-Oliver Wagner jan at
Wed Oct 29 11:16:43 CET 2003

Hi Johan,

you are gessing right that the path to the libshp is perhaps missing.
My first question is: Have you successfully compiled the shapelib package?
If so, there must be some library file.

Another hint: If you feel yourself familiar with the RPM packaging
system, you can download the src-rpm files of shapelib and gen2shp
and create new binary install packages for your Mandrake 9.1.
In case you are not familiar, but interested, I have attached a
html-file which will be part of the next FreeGIS CD release and explains
how to create binary packages yourself.

All the best


On Mon, Oct 27, 2003 at 11:23:42AM +0100, Johan Olanders wrote:
> This time I'm using Mandrake 9.1 GNU/Linux
> gen2shp 0.3.1
> shapelib 1.2.10
> Here are the errors I get
> [johan at frodo gen2shp-0.3.1]$ make
> cc -I /home/johan/greater/preproc -o gen2shp -lshp gen2shp.c utils.o
> /usr//bin/ld: cannot find -lshp
> collect2: ld returned 1 exit status
> make: *** [gen2shp] Error 1
> [johan at frodo gen2shp-0.3.1]$
> I guess it's some kind of problem with paths and I've tried to figure out the 
> right way to solve it without sucess.
> I had the same problems back in UK when running RedHat, that time the problem 
> was solved by using already finished rpm's for gen2shp and shapelib. But they 
> won't install correctly in Mandrake 9.1 (I'm using Mandrake now because my 
> old IBM 6091 screen is more difficult to get working with RedHat.)
> (I remember Jan-Oliver told me last time to specify where to find the 
> and adapt the CFLAGS to this but I can't find a file 
> after uncompressing shapelib 1.2.10)

Jan-Oliver Wagner     

Intevation GmbH	          
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Great-er-list mailing list

This site is hosted by Intevation GmbH (Datenschutzerklärung und Impressum | Privacy Policy and Imprint)