[Thuban-list] Problem with recompile Thuban on Fedora Core 2

Silke Reimer Silke.Reimer at intevation.de
Thu Aug 26 12:40:38 CEST 2004

Hi Marcin,

On Wed, Aug 25, 2004 at 11:41:19PM +0200, Marcin Zaj?czkowski wrote:
> Dnia 2004-08-24 14:34, U?ytkownik Silke Reimer napisa?:
> >Within the last weeks we prepared a FC2 package [1] and ran into
> >similar problems that you report in this email. Mostly this have
> >been encoding problems: default locale on FC2 seems to be an UTF8
> >encoding while thubans internal encoding is latin1. If you pass such
> >a string with special characters to wxGTK this can cause a
> >segmentation fault[2]. There isn't any problem as long as you don't
> >use any special characters.  But if you use a special encoding it is
> >possible that some menus have special characters and then thuban
> >crashes.
> >
> >Some of these issues (for example the about-dialog and the default
> >projections) have been fixed in CVS but there is still a general
> >problem. It can be solved if thuban uses the user's encoding as
> >internal encoding (see bug 2585 [3]).
> >
> >So my first question is: Which encoding do you use? And could you
> >perhaps change it to a latin1-encoding? 
> I use ISO-8859-2 encoding (LANG=pl-PL). I tried with en-US too. But I 
> don't know is it the same problem. Thuban ends its work just after Map 
> -> New Layer (not after start). I tried with my shapes and maps 
> delivered with Thuban.

It seems that indeed that the encoding issue is not your problem -
this has been just a guess by me since this has been the only
problem that I had when compiling thuban on FC2.

> I tried FC2 RPM but I didn't have wxGTK2 and wxPython2 packages (only 
> wxGtk-2.4.2 and wxPython-...), so I had to recompile it from SRPM. I 
> checked current CVS too but always it exited after try to open new layer.
> Can You open any layer even under not UTF-8 encoding?

If wxGTK2 and wxGTK are allowed concurrently on FC2 (I am not sure
about that) you can try to install the official wxGTK2 and wxPython2
package from fedora.us [1]. If this doesn't help to get run thuban
on your system it would be very helpful if you could provide some
gdb traceback. 

Czesc (is this correct for saying Ciao in polish?)


> P.S. Did you use something special to compose last message? It hangs my 
> Mozilla 1.7.2 :)

I did GPG-sign my email. Perhaps this has been the problem? 

[1] http://download.fedora.us/fedora/fedora/2/i386/RPMS.stable/

Silke Reimer

Intevation GmbH                      http://intevation.de/
FreeGIS                                http://freegis.org/

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://www.intevation.de/pipermail/thuban-list/attachments/20040826/f7fa546a/attachment.bin

More information about the Thuban-list mailing list

This site is hosted by Intevation GmbH (Datenschutzerklärung und Impressum | Privacy Policy and Imprint)